Getting Icewind Dale Enhanced Edition to play in Fedora

Continuing the discussion from Discover Icewind Dale:

Specifically, the game from GOG, which comes as a 2.5GB download. It was able to install fine, but when I tried to launch it I got a familiar error:

./IcewindDale64: error while loading shared libraries: cannot open shared object file: No such file or directory

This is a widely discussed issue, because upstream versions of that openssl library is no longer supported in Fedora (for good reason), and yet all these D&D games require it. It is still packages in Ubuntu, which is the solution.

Basically, grab a copy of the .deb from Ubuntu – Package Search Results -- libssl1.0.0. I tried it with a few versions, they all work. Just grab the latest one.

In GNOME you can open .deb with Archive Manager, because that’s what they are. You are also use ar.

Inside the archive is another archive, data.tar.xz, and the libraries you want are in /data/usr/lib/x86_64-linux-gnu:


I read instructions to add them to a lib directory in the same directory as However, upon examining the start script, we see where it actually looks:

 18   local bin32_name="IcewindDale"
 19   local bin64_name="IcewindDale64"
 20   local bin_path32="${CURRENT_DIR}/game/"
 21   local bin_path64="${CURRENT_DIR}/game/"
 22   local lib_path32="${CURRENT_DIR}/game/"
 23   local lib_path64="${CURRENT_DIR}/game/"

At first I changed that to local lib_path64="${CURRENT_DIR}/lib/" and it worked, but I also changed it back and dropped them into /game/ and it works as well (as expected).

Cool! Maybe I can figure out how to get Baldur’s Gate running, too!

1 Like

Making a note that wasn’t the exact error. When I posted this, it was several hours later, and I didn’t have the output any more. But I had searched for that specific string, and was able to find it easily.

Note to @maiki: these notes don’t have to be that elaborate. I can fix this when I post it elsewhere, for archiving. :slight_smile:

1 Like

I kind of wish there were a wiki for these kinds of things with GOG’s catalog. Unraveling some of their installers and getting the games going can be kind of a pain. Hell, I was on a pont-and-click kit earlier this year and had issues unraveling Gabriel Knight for a bit to use in my distro’s vanilla dosbox instead of their prepackaged shenanigans.

For this specific issue I found, which unfortunately didn’t have any info for Fedora. I didn’t read the front page, but it says:

The future of GOGWiki

Ubivis, who created and maintains this wiki, has announced that he will no longer be able to host the GOG Community Wiki, due to limited time, and is looking to hand the reins over to someone else so that the wiki can live on.

On the 1st of June 2018 a backup of the wiki will be made, at which point the wiki will be put into read-only mode so that the backup does not fall out-of-date. The plan is that a new maintainer will be chosen and given the wiki backup so that the entire wiki can be restored onto a new server and full functionality can be restored.

Thank you, Ubivis, for making GOGWiki and for all the hard work you put into it over the years.

Barefoot Monkey 23:37, 16 May 2018 (UTC)

I plan to kinda fill in that knowledge gap, but slowly, one game at time. :slight_smile: