Upgrading: Fedora 28 to 29

I recently upgraded and here are some notes.

Most everything worked, except for the two primary ways I communicate to people… :slight_smile:

First, gajim. Ah, gajim. Well, specifically OMEMO. Took me a while to figure it out, the lock icon won’t interact, and the plugin says it “downloaded”, but it never shows in the active list.

I found omemogajimplugin · Wiki · gajim / gajim-plugins · GitLab, which gives the advice:

To see OMEMO related debug output, start Gajim with the following parameters:

-l gajim.plugin_system.omemo=DEBUG

Which let’s me know what’s happening immediately:

12/12/2018 14:22:09 (W) gajim.plugin_system Plugin omemo not loaded, plugin incompatible with current version of gajim: 1.1.0 > 1.0.90

Hmmm, what can be done?

Well, I follow the installation for Fedora, which is:

Enable copr repository:
dnf copr enable philfry/gajim
For Gajim 1.0:
dnf install python3-axolotl python3-axolotl-curve25519 python3-qrcode

I’ll need to inform someone at Gajim about this, but I’m not sure “Phil Fry” is the person (are they even around this time for more than an afternoon?). Anyhow, I learned about dnf --showduplicates list <package> from fedora - Can I force dnf to install an old version of a package? - Unix & Linux Stack Exchange, so I tried it out:

[maiki@yuzu ~]$ sudo dnf --showduplicates list gajim
Last metadata expiration check: 0:03:19 ago on Wed 12 Dec 2018 02:28:52 PM PST.
Available Packages
gajim.noarch  1.0.3-3.fc29  fedora       
gajim.noarch  1.1.0-1.fc29  philfry-gajim
gajim.src 1.1.0-1.fc29  philfry-gajim

So, uninstall and install of 1.0.3-3.fc29, and my OMEMO plugin is working again!

The second issue I had was tootstream suddenly not finding python. I poked around, but couldn’t figure it out. I considered asking around, but I remembered that virtualenvs are set up for this exact issue, and tootstream isn’t that big, so instead I deleted my venv and just created a new one (named the same, since the script I use to launch it works with a specific path).

And that worked. Like, immediately. My config is kept in my home directory, so I was already “logged in” (meaning I had the key available).

Pretty sure the commands were something like:

mkvirtualenv -p python3 tootstream
workon tootstream
pip install tootstream

Might as well stick my ~/.local/bin/toot here as well:

source /home/maiki/.virtualenvs/tootstream/bin/activate

I don’t know if there are improvements in Fedora, rebooting a laptop does something, or I just have wishful thinking, but my laptop feels snappier than before. And it wasn’t slow! This is my XPS13, and a solid machine. I rarely have issues with performance.

So that’s something. I don’t care enough to track it, but I’d like to know if computers are getting faster, or I’m a sucker like the rest of ya’ll. ^_~

I’m working the gajim issue.

First, system updates came out, so I learned about DNF versionlock Plugin — dnf-plugins-core 4.4.2-1 documentation. So I pinned gajim:

[maiki@yuzu ~]$ sudo dnf versionlock
Last metadata expiration check: 0:03:44 ago on Fri 14 Dec 2018 08:01:53 AM PST.

I think that might actually refer to Philippe Kueck · GitLab, so I’ll message them eventually (head cold winning…). I suppose I use gajim enough to warrant joining their dev server…